Problem
The heat pump is switched on, but the control box does not switch on.
Cause of the problem
If the heat pump does not start, the problem may be due to several elements, including the control box itself, the electronic board or the transformer.
Resolution
3 possibilities:
1) The fault comes from the control box
Make sure that the cable from the control box is well connected. To do this:
- Open the cover (for heat pumps that have a cover)
- Make sure that the cable is well connected
- If the control box still does not light up, check that the voltage at the power supply terminals of the control box on the electronic board, or that the cable is properly connected to the electronic board (see FAQ your control box does not light up)
* If you have 12V, the control box is defective and must be changed.
* If there is no 12V, please refer to point 2
2) The electronic board is defective
🔴Attention🔴 The following manipulations require electrical knowledge and professional help.
To access the electronic board, it is necessary to remove the top cover of the heat pump by removing the screws around it.
Once the cover is removed, please identify the electrical box of the heat pump and remove the cover again. Once removed :
- Ensure that all wires are connected.
- Check that the LED on the electronic board is lit, or flashing.
* If the card is not flashing, it is necessary to measure the power supply upstream of the card, at the electrical connection terminal block (the fault may indeed come from your power supply).
* If the 220V comes but there is no 12V, then please refer to point 3
* If the current is correct (220V and 12V) and the card remains off, it should be replaced.
3) The transformer is defective
In the last case, it is possible that the transformer is responsible for the failure:
- Check the transformer input voltage (220V)
- Check the output voltage (12V)
* If you do not measure any input voltage, the problem is the electronic board
* If you do not measure any output voltage (12V) from the transformer, the problem is the transformer
In case your product is out of warranty (more than 2 years or more than 3 years for the Jetline Premium only), you can order the spare parts on our website.
If your product is still under warranty (less than 2 years or less than 3 years for the Premium range only), open a service file, attaching your purchase invoice and a photo of the problem as an attachment and the serial number.